Skip to main content

 

GovDelivery

Internet Browser Support

Communications Cloud operates on a software as a service (SaaS) platform, offering your organization scalability and automatic upgrades, as well as the opportunity to log in and access your account from anywhere you have an Internet connection.

 

Supported Internet Browsers

Granicus performs regular testing and is committed to supporting the following browsers:

  • Mozilla Firefox 24 or higher
  • Google Chrome 30 or higher
  • Microsoft Internet Explorer 11
If you are having a problem accessing your account, please be sure you have upgraded to the most current version of the browser you are using.

It's possible to use browsers and browser versions that aren't supported by Communications Cloud. However, you might encounter some irregular behavior or unexpected errors doing so. It's recommended that you use one of the supported browsers, or upgrade to a supported browser version.

 

Enabling Javascript and Web Fonts

For full functionality, Communications Cloud also requires JavaScript and web fonts to be enabled within your web browser. Click here for instructions on how to enable JavaScript in your web browser.

 

Troubleshooting

If you are using Microsoft Internet Explorer 11 or higher and are receiving an alert to update your browser, this might indicate that you have Internet Explorer running in Compatibility Mode for Communications Cloud. To remove Communications Cloud from Compatibility Mode:

  1. Click the Tools menu in the top right of your browser.
  2. Select Compatability View settings from that menu. 
  3. In the window that appears, locate GovDelivery.com on the list of sites in the list labeled Websites you've added to Compatibility View.
  4. Click on GovDelivery.com and then click Remove.
  5. Confirm changes and click Close. If needed, refresh Communications Cloud.
  • Was this article helpful?